IFCExtrusion |
Constructs a new instance of a class used to calculate extrusions from Revit geometry.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

public IFCExtrusionCalculatorOptions(
ExporterIFC exporterIFC,
IFCExtrusionAxes extrusionAxes,
XYZ customAxis,
double scale
)
Parameters
- exporterIFC ExporterIFC
- The exporter.
- extrusionAxes IFCExtrusionAxes
- The extrusion axes to try when doing the calculation.
- customAxis XYZ
- The custom axis to try (if extrusionAxes includes an option for a custom direction).
- scale Double
- The scaling factor for length measurements from the default Revit units to the export units.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |