FaceEdgeNode Class


Face Edge Node Class

An output node that represents a Face edge.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FaceEdgeNode : FaceDetailNode

The FaceEdgeNode type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode )
Public property LineProperties Access to the line (pen) properties of the curve being drawn.
(Inherited from FaceDetailNode )
Public property NodeName A readable name of the output node.
(Inherited from RenderNode )
Top
Methods
Name Description
Public method Dispose
(Inherited from RenderNode )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetFaceEdge Returns the Face edge object corresponding to the node.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetInstanceTransform Returns instance transform of the object being drawn.
(Inherited from FaceDetailNode )
Public method GetLinkTransform Returns link transform of the object being drawn.
(Inherited from FaceDetailNode )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
See Also