MemberForcesServiceData Class


Member Forces Service Data Class

The data needed by member forces server to perform type definition.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure MemberForcesServiceData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MemberForcesServiceData : IDisposable

The MemberForcesServiceData type exposes the following members.

Properties
Name Description
Public property Document The current document.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the MemberForcesServiceData
Public method GetCurrentElements Returns the list of Ids of the current elements.
Top
See Also