InstanceVoidCutUtils Class


Instance Void Cut Utils Class

Utilities for cutting elements by unattached voids in family instances.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB InstanceVoidCutUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class InstanceVoidCutUtils

The InstanceVoidCutUtils type exposes the following members.

Methods
Name Description
Public method Static member Code example AddInstanceVoidCut Add a cut to an element using the unattached voids inside a cutting instance.
Public method Static member CanBeCutWithVoid Indicates if the element can be cut by an instance with unattached voids.
Public method Static member GetCuttingVoidInstances Return ids of the instances with unattached voids cutting the element.
Public method Static member GetElementsBeingCut Return ids of the elements being cut by the instance
Public method Static member InstanceVoidCutExists Check whether the instance is cutting the element
Public method Static member IsVoidInstanceCuttingElement Indicates if the element is a family instance with unattached voids that can cut other elements.
Public method Static member Code example RemoveInstanceVoidCut Remove a cut applied to the element by a cutting instance with unattached voids.
Top
See Also