GetAllRebarSpliceTypes Method


Rebar Splice Type Utils Get All Rebar Splice Types Method

Gets all the Rebar Splice Types elements from the document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<ElementId> GetAllRebarSpliceTypes(
	Document document
)

Parameters

document Document
The document.

Return Value

IList ElementId
Returns all the Rebar Splice Types elements from the document.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Internally this function is returning all element ids from a FilteredElementCollector of category BuiltInCategory.OST_RebarSpliceType.
See Also