FabricRoundingManager Class


Fabric Rounding Manager Class

Provides access to element reinforcement roundings overrides.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure ReinforcementRoundingManager
Autodesk.Revit.DB.Structure FabricRoundingManager

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricRoundingManager : ReinforcementRoundingManager

The FabricRoundingManager type exposes the following members.

Properties
Name Description
Public property ApplicableReinforcementRoundingSource Identifies the source of the rounding settings for this element.
Public property ApplicableSegmentLengthRounding The applicable rounding for fabric segments.
Public property ApplicableSegmentLengthRoundingMethod The applicable rounding method for fabric segments.
Public property ApplicableTotalLengthRounding The applicable rounding for Cut Overall Length and Cut Overall Width parameters.
Public property ApplicableTotalLengthRoundingMethod The applicable rounding method for Cut Overall Length and Cut Overall Width parameters.
Public property SegmentLengthRounding The rounding for fabric segments.
Public property SegmentLengthRoundingMethod Identifies the segment length rounding method
Public property TotalLengthRounding The rounding for Cut Overall Length and Cut Overall Width parameters.
Public property TotalLengthRoundingMethod Identifies the total length rounding method
Top
Methods
Name Description
Top
Remarks
An instance of this class can be obtained from specific FabricSheetType or individual FabricSheet or FabricArea elements to apply overrides different from the global settings for the project.
See Also