View |
Validates a shape represented as a collection of geometry objects for use as a view-specific shape. The objects are expected to be either points, curves or polylines. Curves are expected to be flat and lie in a plane perpendicular to view normal as defined by view type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool ValidateShape(
IList<GeometryObject> shape,
DirectShapeTargetViewType targetViewType
)
Parameters
- shape IList GeometryObject
- targetViewType DirectShapeTargetViewType
Return Value
BooleanReturns true if %shape% may be used as a view-specific shape representation, false otherwise.

Exception | Condition |
---|---|
ArgumentException | targetViewType is not DirectShapeTargetViewType::Plan |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |