DisallowJoinAtEnd Method


Structural Framing Utils Disallow Join At End Method

Sets the indicated end of the framing element to not be allowed to join to others.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void DisallowJoinAtEnd(
	FamilyInstance familyInstance,
	int end
)

Parameters

familyInstance FamilyInstance
The FamilyInstance, which must be of a structural framing category.
end Int32
The index of the end (0 for the start, 1 for the end).
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException end must be 0 or 1.
ArgumentsInconsistentException The input familyInstance is not of a structural framing category.
Remarks
If this framing element is already joined at this end, it will become disconnected.
See Also