Structural |
Constructs an instance of StructuralAsset.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- name String
- The name of the asset.
- structuralAssetClass StructuralAssetClass
- The type of structural material that this asset will describe.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |