Light |
This class is the base class for specifying light shape.

System Object
Autodesk.Revit.DB.Lighting LightShape
Autodesk.Revit.DB.Lighting CircleLightShape
Autodesk.Revit.DB.Lighting LineLightShape
Autodesk.Revit.DB.Lighting PointLightShape
Autodesk.Revit.DB.Lighting RectangleLightShape
Autodesk.Revit.DB.Lighting LightShape
Autodesk.Revit.DB.Lighting CircleLightShape
Autodesk.Revit.DB.Lighting LineLightShape
Autodesk.Revit.DB.Lighting PointLightShape
Autodesk.Revit.DB.Lighting RectangleLightShape
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The LightShape type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Clone | Creates a copy of the LightShape derived object. |
![]() | Dispose | Releases all resources used by the LightShape |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |