Stairs |
Set location path for a straight run by giving a line.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool SetLocationPathForStraightRun(
StairsRun stairsRun,
Line locationPath
)
Parameters
Return Value
BooleanIndicate if set is success or not.

Exception | Condition |
---|---|
ArgumentException | The input locationPath is not a bound line. -or- The input locationPath is not a valid location path line for straight run. -or- The locationPath is not valid line used as stairs path(probably it's too short). |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The stairs element represented by stairsRun is not in an active StairsEditScope. The run cannot be modified. |
RegenerationFailedException | The locationPath doesn't satisfy restrictions to generate straight run. |