AddElementIds Method


Structural Connection Handler Add Element Ids Method

Adds element ids to the connection. All element ids in an array should be of applicable category.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddElementIds(
	IList<ElementId> elemIds
)

Parameters

elemIds IList ElementId
The ElementIdArr containing ids of elements to be added.
Exceptions
Exception Condition
ArgumentException One or more element ids was not permitted to be add to the connection. Elements should be of applicable category. -or- One or more element ids was not permitted to be added to the connection. Elements should not be duplicated.
ArgumentNullException A non-optional argument was null
See Also