Curve |
Creates an area based load boundary line.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static CurveElement CreateAreaBasedLoadBoundaryLine(
Document document,
Curve curve,
ElementId levelId
)
Parameters
- document Document
- The document in which to create the area based load boundary line.
- curve Curve
- The curve.
- levelId ElementId
- The id of level.
Return Value
CurveElementThe newly created area based load boundary line.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- The input curve is not bound. -or- The curve is degenerate (its length is too close to zero). -or- The ElementId levelId is not a Level. -or- The curve doesn't lie in the plane of the level. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |