IStructuralSectionsServer Interface


IStructural Sections Server Interface

Interface for the section type parameter server to implement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IStructuralSectionsServer : IExternalServer

The IStructuralSectionsServer type exposes the following members.

Methods
Name Description
Public method GetDescription Implement this method to return a description of the server.
(Inherited from IExternalServer )
Public method GetName Implement this method to return the name of the server.
(Inherited from IExternalServer )
Public method GetServerId Implement this method to return the id of the server.
(Inherited from IExternalServer )
Public method GetServiceId Implement this method to return the id of the service.
(Inherited from IExternalServer )
Public method GetVendorId Implement this method to return the id of the vendor of the server.
(Inherited from IExternalServer )
Public method StructuralSectionsUpdate The server's method that will be called when Revit User clicks the Section Type parameter's button in the family dialog.
Top
See Also