VertexPosition Class


Vertex Position Class

A geometry vertex specified as a position in space.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D Vertex
Autodesk.Revit.DB.DirectContext3D VertexPosition

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class VertexPosition : Vertex

The VertexPosition type exposes the following members.

Constructors
Name Description
Public method VertexPosition Constructs the vertex from a point.
Top
Properties
Name Description
Public property Position The vertex's position.
Top
Methods
Name Description
Public method Static member GetSizeInFloats Gets the amount of storage that the vertex takes up in a buffer, measured in floats.
Top
Remarks
Since these vertices do not have a color their color is obtained from the EffectInstance
See Also