RebarCurvesData Class


Rebar Curves Data Class

The class that contains the information needed to calculate and return the result of the external curve generation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarCurvesData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarCurvesData : IDisposable

The RebarCurvesData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method AddBarGeometry(CurveLoop) Adds a new bar to the new rebar geometry. This information is set to the rebar after the API execution is finished successfully.
Public method AddBarGeometry(IList Curve ) Adds a new bar to the new rebar geometry. This information is set to the rebar after the API execution is finished successfully.
Public method CanAddBarGeometry

If the layout rule is Singe or FixedNumber or NumberWithSpacing this function will return true if getNumberOfBarGeometry() is less getBarsNumber(), false otherwise.

If the layout rule is MaximumSpacing or MinimumClearSpacing this function will return always true.

Public method ClearAllAddedBarGeometry This function will remove all bars geometry that were added by calling AddBarGeometry().
Public method Dispose Releases all resources used by the RebarCurvesData
Public method GetAddedBarGeometry Gets the added curves that will represent the bar at index barIndex.
Public method GetDistributionPath Gets the distribution path currently stored in the rebar.
Public method GetNumberOfBarGeometry Gets the number of Bar Geometry that were added.
Public method GetRebarUpdateCurvesData Gets a class that contains information used as input and output for rebar free form calculation.
Public method SetDistributionPath Sets a new distribution path to be applied to the rebar. This information is set to the rebar after the API execution is finished successfully.
Top
See Also