AnalysisDisplayColorEntry Class


Analysis Display Color Entry Class

Contains one entry of intermediate colors in color settings for analysis display style.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis AnalysisDisplayColorEntry

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AnalysisDisplayColorEntry : IDisposable

The AnalysisDisplayColorEntry type exposes the following members.

Constructors
Name Description
Public method AnalysisDisplayColorEntry Constructs a new AnalysisDisplayColorEntry with default settings.
Public method AnalysisDisplayColorEntry(Color) Constructs a color entry with no value assigned.
Public method AnalysisDisplayColorEntry(Color, Double) Constructs a color entry with a specific value assigned.
Top
Properties
Name Description
Public property Color Color associated with color entry.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Value Value associated with color entry.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the AnalysisDisplayColorEntry
Public method HasValue Check if color entry has associated value.
Public method IsEqual Compare color entries.
Top
See Also