SchemaCommon Class


Schema Common Class

A static class that provides access to the property names that appear in all the visual Asset types.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual SchemaCommon

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class SchemaCommon

The SchemaCommon type exposes the following members.

Properties
Name Description
Public property Static member BaseSchema The property labeled "BaseSchema" common to all visual Asset types.
Public property Static member Category The property labeled "Category" common to all visual Asset types.
Public property Static member Description The property labeled "Description" common to all visual Asset types.
Public property Static member Hidden The property labeled "Hidden" common to all visual Asset types.
Public property Static member Keyword The property labeled "Keyword" common to all visual Asset types.
Public property Static member Thumbnail The property labeled "Thumbnail" common to all visual Asset types.
Public property Static member UIName The property labeled "UIName" common to all visual Asset types.
Public property Static member VersionGUID The property labeled "VersionGUID" common to all visual Asset types.
Top
See Also