Item |
Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public FamilyInstance NewFamilyInstance(
XYZ origin,
FamilySymbol symbol,
View specView
)
Parameters
- origin XYZ
- The origin of family instance. If created on a ViewPlan , the origin will be projected onto the ViewPlan .
- symbol FamilySymbol
- A family symbol object that represents the type of the instance that is to be inserted.
- specView View
- The 2D view in which to place the family instance.
Return Value
FamilyInstanceIf creation was successful then an instance to the new object is returned.

Exception | Condition |
---|---|
ArgumentNullException | One or more required arguments was |
ArgumentException | The input family PlacementType was not ViewBased, the input view was not 2D, Thrown if The symbol is not active. or instances of the input FamilySymbol are not permitted on a view of this type. |

This overload applies only to 2D family symbols (detail components, annotation symbols, titleblocks, etc.). The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.