SetAdditionalReferencesToDimension Method


Multi Reference Annotation Options Set Additional References To Dimension Method

Sets the additional references which the dimension will witness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetAdditionalReferencesToDimension(
	IList<Reference> referencesToDimension
)

Parameters

referencesToDimension IList Reference
The additional references which the dimension will witness.
Exceptions
Exception Condition
ArgumentException Some references come from elements which directly match the reference category required by the MultiReferenceAnnotationType. For those elements please use SetElementsToDimension.
ArgumentNullException A non-optional argument was null
Remarks
The additional references to dimension cannot come from the same category as the MultiReferenceAnnotationType's reference category.
See Also