Base |
A base class containing import options used during import of several formats.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The BaseImportOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. |
![]() | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. |
![]() | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) |
![]() | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. |
![]() | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. |
![]() | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. |
![]() | Unit | The unit of measure for imported geometry. |
![]() | VisibleLayersOnly | Only import the visible layers. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the BaseImportOptions |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetLayerSelection | Get all set layers name which user want to import into Revit. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. |
![]() | SetLayerSelection | Set the layers name which user want to import into Revit. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Reference

System Object
Autodesk.Revit.DB BaseImportOptions
Autodesk.Revit.DB AXMImportOptions
Autodesk.Revit.DB DGNImportOptions
Autodesk.Revit.DB DWGImportOptions
Autodesk.Revit.DB ImportOptions3DM
Autodesk.Revit.DB OBJImportOptions
Autodesk.Revit.DB SATImportOptions
Autodesk.Revit.DB SKPImportOptions
Autodesk.Revit.DB STEPImportOptions
Autodesk.Revit.DB STLImportOptions
Autodesk.Revit.DB BaseImportOptions
Autodesk.Revit.DB AXMImportOptions
Autodesk.Revit.DB DGNImportOptions
Autodesk.Revit.DB DWGImportOptions
Autodesk.Revit.DB ImportOptions3DM
Autodesk.Revit.DB OBJImportOptions
Autodesk.Revit.DB SATImportOptions
Autodesk.Revit.DB SKPImportOptions
Autodesk.Revit.DB STEPImportOptions
Autodesk.Revit.DB STLImportOptions