AdvancedMetal Class


Advanced Metal Class

A static class that provides access to the property names that appear in the AdvancedMetal visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual AdvancedMetal

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class AdvancedMetal

The AdvancedMetal type exposes the following members.

Properties
Name Description
Public property Static member MetalF0 The property labeled "Reflectance" from the "AdvancedMetal" schema.
Public property Static member SurfaceAlbedo The property labeled "Color" from the "AdvancedMetal" schema.
Public property Static member SurfaceAnisotropy The property labeled "Anisotropy" from the "AdvancedMetal" schema.
Public property Static member SurfaceCutout The property labeled "Image" from the "AdvancedMetal" schema.
Public property Static member SurfaceNdfType The property labeled "NDF" from the "AdvancedMetal" schema.
Public property Static member SurfaceNormal The property labeled "Image" from the "AdvancedMetal" schema.
Public property Static member SurfaceRotation The property labeled "Rotation" from the "AdvancedMetal" schema.
Public property Static member SurfaceRoughness The property labeled "Roughness" from the "AdvancedMetal" schema.
Top
See Also