CommandMenuItem Constructor


Command Menu Item Constructor

Initialize the item data.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public CommandMenuItem(
	string name,
	string className,
	string assemblyName
)

Parameters

name String
The name will show on menu.
className String
The class name which implements IExternalCommand interface.
assemblyName String
The path of the assembly which contains the corresponding external command.
Exceptions
Exception Condition
ArgumentException name is an empty string or contains only whitespace. -or- className is an empty string or contains only whitespace. -or- assemblyName is an empty string or contains only whitespace.
ArgumentNullException A non-optional argument was null
See Also