ElementPhaseStatusFilter Class


Element Phase Status Filter Class

A filter used to match elements that have a given phase status on a given phase.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementPhaseStatusFilter : ElementSlowFilter

The ElementPhaseStatusFilter type exposes the following members.

Constructors
Name Description
Public method ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) Constructs a new instance of a file to match elements that have a given phase status on the input phase.
Public method ElementPhaseStatusFilter(ElementId, ICollection ElementOnPhaseStatus ) Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.
Public method ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus, Boolean) Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.
Public method ElementPhaseStatusFilter(ElementId, ICollection ElementOnPhaseStatus , Boolean) Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.
Top
Properties
Name Description
Public property Inverted True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter )
Public property PhaseId The phase id.
Top
Methods
Name Description
Public method Dispose
(Inherited from ElementFilter )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetPhaseStatuses Returns the phase statuses assigned to this filter.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method PassesFilter(Element) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method PassesFilter(Document, ElementId) Applies the filter to a given element.
(Inherited from ElementFilter )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
See Also