FailureResolutionType Enumeration


Failure Resolution Type Enumeration

Enumeration to classify FailureResolutions by nature of operation they perform on failing Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum FailureResolutionType
Members
Member name Value Description
Invalid 0 Special (reserved) type. This should be non-initialized value of any variable of FailureResolutionType, end user should not see this value, API programmer could use this in initialization and comparison.
Default 1 Special (reserved) type. It cannot be used as a type when defining a resolution, but can be used as a key to query default resolution from FailureMessage or FailureDefinition.
CreateElements 2 Defines a resolution of a failure where Revit will add new Element(s) in place of missing one(s).
DeleteElements 3 Defines a resolution of a failure by deleting Element(s) that caused the failure.
SkipElements 4 Defines a resolution of a failure by skipping Element(s) for which operation has failed and proceeding with the rest of Elements.
MoveElements 5 Defines a resolution of a failure by moving Element(s) to an appropriate location.
FixElements 6 Defines a resolution of a failure by changing failing Element(s) - specific change may vary depending in type of failure and type of Element(s).
DetachElements 7 Defines a resolution of a failure by removing invalid relationships between elements such as joined walls and roofs, grouped elements, and associated curves.
QuitEditMode 8 Defines a resolution of a failure by quitting an Edit Mode instead of committing changes. Changes made in edit mode will be rolled back.
UnlockConstraints 9 Defines a resolution of a failure by unconstraining Element(s).
SetValue 10 Defines a resolution of a failure by setting an appropriate value in place of invalid value.
SaveDocument 11 Save the current document to avoid losing more if something serious occurs.
ShowElements 12 The standard "Show" may fail in some context, special resolution could be added in this condition to show failing element(s).
Others 100,000 Resolution type does not match any of the above.
See Also