IsValidNamingCategory Method


Assembly Instance Is Valid Naming Category Method

Identifies if the naming category is valid for an assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidNamingCategory(
	Document document,
	ElementId namingCategoryId,
	ICollection<ElementId> assemblyMemberIds
)

Parameters

document Document
The document for the assembly instance.
namingCategoryId ElementId
The id of the naming category for the assembly instance.
assemblyMemberIds ICollection ElementId
Member ids to check validity of naming category

Return Value

Boolean
True if the naming category is valid, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also