CreateBound Method


Line Create Bound Method

Creates a new instance of a bound linear curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Line CreateBound(
	XYZ endpoint1,
	XYZ endpoint2
)

Parameters

endpoint1 XYZ
The first line endpoint.
endpoint2 XYZ
The second line endpoint.

Return Value

Line
The new bound line.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was NULL
ArgumentsInconsistentException Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Example
// define start and end for bound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 10);

// create line
Line line = Line.CreateBound(startPoint, endPoint);
See Also