Autodesk.Revit.DB.ExtensibleStorage Namespace


Autodesk. Revit. DB. Extensible Storage Namespace

Classes
Class Description
Public class DataStorage An element which allows an API applications to organize and store data.
Public class Entity An object stored in the Extensible Storage framework. An Entity is described by a Schema, which serves both to identify an Entity, and to describe its contents (Fields).
Public class ExtensibleStorageFilter A filter used to filter elements with extensible storage data based on specific Schema id.
Public class Field The description of a field within a Schema in the Extensible Storage framework. Contains the field's name, type, access control and documentation.
Public class FieldBuilder This class is used to create Fields in the Extensible Storage framework.
Public class Schema The description of a single object (Entity) in the Extensible Storage framework. Contains identity information, documentation and the list of fields to be stored in the Entity.
Public class Code example SchemaBuilder This class is used to create Schemas in the Extensible Storage framework.
Enumerations
Enumeration Description
Public enumeration AccessLevel Defines access levels to objects in the Extensible Storage framework.
Public enumeration ContainerType An enumerated type indicating if the field represents a single value or a container of multiple values.