AllowsVisibilityControl Property


Category Allows Visibility Control Property

Whether the visibility can be controlled by the user for this category in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool this[
	View view
] { get; }

Parameters

view View
The view where visibility control might be allowed.

Property Value

Boolean
Remarks
There are some categories in Revit that are hidden to users in the Object Styles and Visibility dialog. Their visibility cannot be controlled for a particular view. This property identifies if the category allows visibility control (and thus allows the Visible property to be set).
See Also