RoutingPreferenceRuleGroupType Enumeration


Routing Preference Rule Group Type Enumeration

Add more rule group type here.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum RoutingPreferenceRuleGroupType
Members
Member name Value Description
Segments 0 The segment types (e.g. pipe stocks)
Elbows 1 The elbow types.
Junctions 2 The junction types (e.g. takeoff, tee, wye, tap).
Crosses 3 The cross types.
Transitions 4 The transition types (Note that the multi-shape transitions may have their own groups).
Unions 5 The union types that connect two segments together.
MechanicalJoints 6 The mechanical joint types that connect fitting to fitting, segment to fitting, or segment to segment.
TransitionsRectangularToRound 7 The multi-shape transition from the rectangular profile to the round profile.
TransitionsRectangularToOval 8 The multi-shape transition from the rectangular profile to the oval profile.
TransitionsOvalToRound 9 The multi-shape transition from the oval profile to the round profile.
Undefined -1 The undefined group type, the default initial value.
Caps 10 The cap types
See Also