TestCell Method


Point Cloud Filter Test Cell Method

Checks whether a given cell, i.e. a box aligned with the XYZ axes, is inside, outside or on the border of the volume of interest.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int TestCell(
	XYZ min,
	XYZ max
)

Parameters

min XYZ
The lower corner of the cell.
max XYZ
The upper corner of the cell.

Return Value

Int32
  • -1 -- The cell is entirely rejected.
  • 0 -- The cell partially belongs to the volume of interest. Use PrepareForCell() and TestPoint() to evaluate individual points.
  • 1 -- The cell is fully accepted.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also