Direction Property


Rebar Shape Constraint Angle From Fixed Dir Direction Property

A fixed direction in UV-space. The parameter will drive the segment's angle relative to this direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public UV Direction { get; set; }

Property Value

UV
Exceptions
Exception Condition
ArgumentNullException When setting this property: A non-optional argument was null
ArgumentOutOfRangeException When setting this property: direction has zero length.
See Also