GetTopLevelLink Method (Document, ModelPath)


Revit Link Type Get Top Level Link(Document, Model Path) Method

Returns the ElementId of the (top-level) linked model with the given path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementId GetTopLevelLink(
	Document document,
	ModelPath path
)

Parameters

document Document
The document to look for the linked model in.
path ModelPath
A path indicating which linked model to return.

Return Value

ElementId
The id of the link with the given path, or InvalidElementId if there is no top-level link at that path.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This function will not return nested links.
See Also