SetPipeSlopes Method


Pipe Settings Set Pipe Slopes Method

Set pipe slope values.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetPipeSlopes(
	IList<double> slopes
)

Parameters

slopes IList Double
Pipe slope values. Revit stores the slope value as a percentage (0-100).
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException Each value of the slopes must be between 0 and 100. Slope value is stored in percentage. e.g. 100 means 100%, and it is 45 degree.
InvalidOperationException This operation failed.
See Also