CalculateFaceAlignment Method


Extrusion Analyzer Calculate Face Alignment Method

Calculates the alignment status of each face of the solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IDictionary<Face, ExtrusionAnalyzerFaceAlignment> CalculateFaceAlignment()

Return Value

IDictionary Face , ExtrusionAnalyzerFaceAlignment
Maps each face of the solid to its alignment status.
Remarks
You can obtain the element which produced the non-aligned face by passing the face to Element.GetGeneratingElementIds().
See Also