ProfilePlaneLocation Enumeration


Profile Plane Location Enumeration

Indicates the location of Sweep profile plane on the path curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum ProfilePlaneLocation
Members
Member name Value Description
Start 0 Indicates the profile plane located at the start of the path curve.
MidPoint 1 Indicates the profile plane located at the Middle point of the path curve.
End 2 Indicates the profile plane located at the End of the path curve.
Remarks
Use this enum in the NewSweep() method to create generic forms.
See Also