Edge |
An array of edge arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The EdgeArrayArray type exposes the following members.

Name | Description | |
---|---|---|
![]() | EdgeArrayArray | Initializes a new instance of the EdgeArrayArray class |

Name | Description | |
---|---|---|
![]() | IsEmpty | Test to see if the array is empty. |
![]() | Item | Gets or sets an edge array at a specified index within the array. |
![]() | Size | Returns the number of edge arrays that are in the array. |

Name | Description | |
---|---|---|
![]() | Append | Add the edge array to the end of the array. |
![]() | Clear | Removes every edge array from the array, rendering it empty. |
![]() | ForwardIterator | Retrieve a forward moving iterator to the array. |
![]() | GetEnumerator | Retrieve a forward moving iterator to the array. |
![]() | Insert | Insert the specified edge array into the array. |
![]() | ReverseIterator | Retrieve a backward moving iterator to the array. |

public void GetEdgeArrayArray(Autodesk.Revit.ApplicationServices.Application app, Autodesk.Revit.DB.Element element)
{
// Get geometry element of the selected element
Options geoOptions = app.Create.NewGeometryOptions();
Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);
// Get geometry object
foreach (GeometryObject o in geoElement)
{
Solid solid = o as Solid;
if (null != solid)
{
foreach (Face face in solid.Faces)
{
if (face != null)
{
EdgeArrayArray edgeArrays = face.EdgeLoops;
foreach (EdgeArray edges in edgeArrays)
{
foreach (Edge edge in edges)
{
// Get one test point
XYZ testPoint = edge.Evaluate(0.5);
string edgeInfo = string.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z);
TaskDialog.Show("Revit",edgeInfo);
}
}
}
}
}
}
}