ExportLinetypeKey Class


Export Linetype Key Class

A key used to represent an item stored in an ExportLinetypeTable .
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportLinetypeKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportLinetypeKey : IDisposable

The ExportLinetypeKey type exposes the following members.

Constructors
Name Description
Public method ExportLinetypeKey Constructs a new default ExportLinetypeKey.
Public method ExportLinetypeKey(ExportLinetypeKey) Constructs a new copy of the input ExportLinetypeKey object.
Public method ExportLinetypeKey(String) Constructs a new default ExportLinetypeKey using the original line type name as input.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property OriginalLinetypeName The original linetype name.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExportLinetypeKey
Top
See Also