GetConstraintCandidatesForHandle Method (RebarConstrainedHandle, ElementId)


Rebar Constraints Manager Get Constraint Candidates For Handle(Rebar Constrained Handle, Element Id) Method

For shape driven rebar returns all possible RebarConstraints belonging to references from the provided element that could be used for a specified RebarConstrainedHandle.

For free form rebar will return an empty list.


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<RebarConstraint> GetConstraintCandidatesForHandle(
	RebarConstrainedHandle handle,
	ElementId elementId
)

Parameters

handle RebarConstrainedHandle
The RebarConstrainedHandle for which constraint candidates are sought.
elementId ElementId
The elementId ( host or rebar ) of the element in which the candidates are searched for. It can be any host in the model or any bar from any host.

Return Value

IList RebarConstraint
A collection of RebarConstraints
Exceptions
Exception Condition
ArgumentException elementId is not a valid RebarConstraint target element.
ArgumentNullException A non-optional argument was null
InvalidOperationException The RebarConstraintsManager does not manage a valid Rebar element.
Remarks
Will throw exception if the provided elementId is not a valid constraint target.
See Also