GetIFCClassNameByCategory Method


Exporter IFCUtils Get IFCClass Name By Category Method

Note: This API is now obsolete.

Obtains the IFC class name associated to a given category id for the current export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
[ObsoleteAttribute("This function is deprecated in Revit 2025.  Please use ExporterIFC.GetCategoryMappingTable instead.")]
public static string GetIFCClassNameByCategory(
	ElementId catId,
	ExporterIFC exporterIFC
)

Parameters

catId ElementId
The category id.
exporterIFC ExporterIFC
The exporter.

Return Value

String
The IFC class name. This is an empty string if the element should not be exported because it is not found in the mapping file.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
IFC class names are affected by the user's entries in the mapping file set for a given export operation.
See Also