Family |
Gets the profile Family Symbols of the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ICollection<ElementId> GetProfileSymbols(
Document document,
ProfileFamilyUsage profileFamilyUsage,
bool oneCurveLoopOnly
)
Parameters
- document Document
- The document.
- profileFamilyUsage ProfileFamilyUsage
- The profile family usage.
- oneCurveLoopOnly Boolean
- Whether or not to return only profiles with one curve loop.
Return Value
ICollection ElementIdThe set of profile Family Symbol element ids.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |