Failure |
Defines a resolution for a failure.

System Object
Autodesk.Revit.DB FailureResolution
Autodesk.Revit.DB DeleteElements
Autodesk.Revit.DB DisableAnalyticalModelCB
Autodesk.Revit.DB FailureResolution
Autodesk.Revit.DB DeleteElements
Autodesk.Revit.DB DisableAnalyticalModelCB
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FailureResolution type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FailureResolution |

A failure could have several permitted resolutions. List of applicable resolution types for the specific failure is defined by the FailureDefinition, actual FailureResolutions are instantiated with the FailureMessage before it is posted. Multiple resolutions per failure are allowed, although Revit UI only uses default resolution.