CreateCableTrayConnector Method (Document, Reference, Edge)


Connector Element Create Cable Tray Connector(Document, Reference, Edge) Method

Create a new cable tray ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ConnectorElement CreateCableTrayConnector(
	Document document,
	Reference planarFace,
	Edge edge
)

Parameters

document Document
The document to add the connector to.
planarFace Reference
The planar face to place the connector on.
edge Edge
One of the edges in the edge loop that defines the connector location on the planar face.

Return Value

ConnectorElement
The cable tray ConnectorElement.
Exceptions
Exception Condition
ArgumentException The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face.
ArgumentNullException A non-optional argument was null
InvalidOperationException Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also