ProductType Enumeration


Product Type Enumeration

An enumerated type containing the possible Revit product types.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum ProductType
Members
Member name Value Description
Architecture 0 Architecture.
Structure 1 Structure.
MEP 2 MEP.
Revit 3 Revit.
LT 4 LT.
Unknown 5 Unknown.
See Also