CreateRibbonPanel Method (Tab, String)


UIControlled Application Create Ribbon Panel(Tab, String) Method

Create a new RibbonPanel on the designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual RibbonPanel CreateRibbonPanel(
	Tab tab,
	string panelName
)

Parameters

tab Tab
The target tab, on which the new panel will be created.
panelName String
The name of the panel to be created.

Return Value

RibbonPanel
Exceptions
Exception Condition
ArgumentNullException panelName is .
ArgumentException panelName is Empty or the tab is not valid.
InvalidOperationException If more than 100 panels were created or the tab cannot be found.
Remarks
This method will create a custom panel appending to the specified tab. This method is not supported in Macros.
See Also