ConvertDuctPlaceholders Method


Mechanical Utils Convert Duct Placeholders Method

Converts a collection of duct placeholder elements into duct elements.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ICollection<ElementId> ConvertDuctPlaceholders(
	Document document,
	ICollection<ElementId> placeholderIds
)

Parameters

document Document
The document.
placeholderIds ICollection ElementId
A collection of element IDs of duct placeholders.

Return Value

ICollection ElementId
A collection of element IDs of ducts and fittings.
Exceptions
Exception Condition
ArgumentException The given element id set is empty. -or- The given element IDs (placeholderIds) are not duct placeholders. -or- The elements belong to different types of system.
ArgumentNullException A non-optional argument was null
Remarks
Once conversion succeeds, the duct placeholder elements are deleted. The new duct and fitting elements are created and connections are established.
See Also