GetChildIds Method


Revit Link Type Get Child Ids Method

Gets the ids of the immediate children of this link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ICollection<ElementId> GetChildIds()

Return Value

ICollection ElementId
The element ids of all links which are linked directly into this one (immediate children)
Remarks
This function only returns the ids of immediate children. Given the link structure A -> B -> C, then calling this function on A will only return B's id.
See Also