SchedulableField Class


Schedulable Field Class

A non-calculated field eligible to be included in a schedule.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB SchedulableField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SchedulableField : IDisposable

The SchedulableField type exposes the following members.

Constructors
Name Description
Public method SchedulableField Creates a new SchedulableField.
Public method SchedulableField(Guid) Creates a new SchedulableField.
Public method SchedulableField(ScheduleFieldType) Creates a new SchedulableField.
Public method SchedulableField(ScheduleFieldType, ElementId) Creates a new SchedulableField.
Top
Properties
Name Description
Public property FieldType The type of data displayed by the field.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property ParameterId The ID of the parameter displayed by the field.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the SchedulableField
Public method Equals Determines whether the specified Object is equal to the current Object .
(Overrides Object Equals(Object) )
Public method GetCustomFieldData Gets the data associated with this custom field. If this field isn't a CustomField will return .
Public method GetHashCode Gets the integer value of the SchedulableField as hash code
(Overrides Object GetHashCode )
Public method GetName Gets the name of the field.
Top
Operators
Name Description
Public operator Static member Equality(SchedulableField, SchedulableField) Determines whether two SchedulableField are the same.
Public operator Static member Inequality(SchedulableField, SchedulableField) Determines whether two SchedulableField are different.
Top
Remarks
The SchedulableField class represents a non-calculated field that is eligible to be included in a schedule. A list of fields that can be included in a schedule can be obtained from ScheduleDefinition.GetSchedulableFields.
See Also