Angle Property


Connector Angle Property

The angle of the Connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double Angle { get; set; }

Property Value

Double
Exceptions
Exception Condition
InvalidOperationException Thrown when the connector's domain is not DomainHvac, DomainPiping, or DomainCableTrayConduit. Thrown when set value for the connector not in family instance.
ArgumentException Thrown when setting an invalid value.
InvalidOperationException Thrown on failure to set angle.
Remarks
Angle may be assigned for connectors of some family instances. In order to set this property, it must be mapped to a writable instance parameter in the family definition. For a connector obtained from a non-family instance (for example not a fitting, but instead a pipe, duct, or cable tray), the value will always be zero. Non-zero angles are only valid for family instance fitting connectors.
See Also