Schedule |
Sets the FormatOptions to optionally override the default settings in the Units class.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- formatOptions FormatOptions
- The FormatOptions.

Exception | Condition |
---|---|
ArgumentException | The display unit in formatOptions is not a valid display unit for the unit type of this ScheduleField, or the rounding method in formatOptions is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod. |
ArgumentNullException | A non-optional argument was null |

See the UnitType property to determine the unit type of this field.

// format length units to display in feet and inches format
public void FormatLengthFields(ViewSchedule schedule)
{
int nFields = schedule.Definition.GetFieldCount();
for (int n = 0; n < nFields; n++)
{
ScheduleField field = schedule.Definition.GetField(n);
if (field.GetSpecTypeId() == SpecTypeId.Length)
{
FormatOptions formatOpts = new FormatOptions();
formatOpts.UseDefault = false;
formatOpts.SetUnitTypeId(UnitTypeId.FeetFractionalInches);
field.SetFormatOptions(formatOpts);
}
}
}